« Linux Mint 19.1 MATE update Error bionic-security/restricted armhf Packages | Main | Linux Mint 19.1 に Virus 対応ソフト ClamAV を Install »

04/30/2019

tp-link Archer T1U v2 AC450 を Linux Mint 19.1 で使う

Archer T1U v2 AC450 を Linux Mint 19.1 で使おうとして、ネット上をいろいろ探し回って、出来ることは殆ど試してみたが、全て失敗した。
そんなとき、ここ( https://askubuntu.com/questions/1083281/cant-install-driver-for-tp-link-t1u-usb-on-ubuntu-18-04-kernel-4-15-0-36-gener )にある書込み「Kernel 4.19 has a working drive. 」を見つけた!

そこで、自分が MacBook Proに入れている Linux Mint 19.1 の kernel のバージョンを確認してみた。
$ uname -r 
4.15.0-48-generic  と表示された。

これを書いている 2019/4/30 時点での最新カーネルをアップデートマネージャで調べる(下記のようにして)、
アップデートマネージャ(画面右下にある盾のアイコン) > ツールメニューから「表示」をクリックして、調べると、
4.18.0-18 
になっている。 これではまだ Archer T1U v2 AC450 を動かせる driver はインストールされていないかも知れない。
それで、kernel を 4.19 にする方法を調べてみた。

kernel を 4.19 にするアップデートのやり方は、
ここ( MANIAC How to : Update Kernel 4.19 stable on Ubuntu / Linux Mint system )に記載されているので、そのまま試してみた!

Terminal を開いて、下記コマンドを実行する・・・(コピーしたものを貼り付けるが、上記のURLからコピーするのが良いだろう。)

wget http://kernel.ubuntu.com/~kernel-ppa/mainline/v4.19/linux-headers-4.19.0-041900_4.19.0-041900.201810221809_all.deb \\ http://kernel.ubuntu.com/~kernel-ppa/mainline/v4.19/linux-headers-4.19.0-041900-generic_4.19.0-041900.201810221809_amd64.deb \\ http://kernel.ubuntu.com/~kernel-ppa/mainline/v4.19/linux-headers-4.19.0-041900-lowlatency_4.19.0-041900.201810221809_amd64.deb \\ http://kernel.ubuntu.com/~kernel-ppa/mainline/v4.19/linux-image-unsigned-4.19.0-041900-generic_4.19.0-041900.201810221809_amd64.deb \\ http://kernel.ubuntu.com/~kernel-ppa/mainline/v4.19/linux-image-unsigned-4.19.0-041900-lowlatency_4.19.0-041900.201810221809_amd64.deb \\ http://kernel.ubuntu.com/~kernel-ppa/mainline/v4.19/linux-modules-4.19.0-041900-generic_4.19.0-041900.201810221809_amd64.deb \\ http://kernel.ubuntu.com/~kernel-ppa/mainline/v4.19/linux-modules-4.19.0-041900-lowlatency_4.19.0-041900.201810221809_amd64.deb

インストールの途中で、
wget : ホストアドレス '\\' を解決できませんでした・・・ などの表示が出るが、そのまま実行を続ける・・・ 
8分24秒かかって終了。

この処理が終わった後、まだ再起動せず、URLにあるように下記のコマンドを打ち込む。

$ sudo dpkg -i *.deb
を実行して・・・ 途中 ERROR 表示はあるが・・・ 完了。

その後、再起動!
$ sudo reboot 

リブート後、 早速、カーネルバージョンの確認
$ uname -r 
と打ち込み、 4.19.0-041900-lowlatency  と表示された。

早速、Archer T1U v2 AC450 を USBポートに差し込んで WiFi 接続を確認した。

WiFiネットワーク( MediaTek WiFi )
インターフェース: 802.11 Wi-Fi
ドライバー: mt76x0
速度: 120~150Mb/s   (私が使っているWiFiルーターは、 AirStation WSR-2533DHP2 仕様では、5GHz帯接続時は最大1733Mbps となっている。電波状態は良いはずなので、AC450 は、規格値の 433Mbps にもっと近づいた値を示しても良いはずなんだが・・・)

比較のためのデータを書いておくと、
実は、Archer T1U v2 AC450 を購入して試すも、全く繋がらないので、諦めて Buffalo 無線LAN子機 WI-U2-433DMS を追加購入して、MacBook Pro で試していた。
その結果、kernel のアップデートも必要なく、USBポートに挿し込んで、Linux Mint 19.1 で無調整で、すぐに使うことが出来た。
その状態での速度は、 434Mb/s と表示されている。

ドングルの形が小さいArcher T1U v2 AC450 を気に入って購入したが、MacBook Pro 内臓のWiFi でも 270Mb/s の速度は出てくれる。
Buffalo 無線LAN子機 WI-U2-433DMS の方がいいなぁ。 僕は、ちょっと無駄な買い物をしてしまったような気がする。

注意
kernel を 4.19 にアップデート後、僕のMacBook Pro は、システムが不安定になった。
デスクトップ画面で作業中、「画面が黒字の ログイン画面に切り替わる」これは頻繁に発生する。画面は数秒で元に戻る。WiFi通信が頻繁に切れる。
これらの事を容認できないなら、カーネルのアップデートは、公式にサポートされるまでは、やめた方が良いと思う。 僕はこれから、 Linux Mint を再度クリーンインストールしようとしているところだから・・・。

« Linux Mint 19.1 MATE update Error bionic-security/restricted armhf Packages | Main | Linux Mint 19.1 に Virus 対応ソフト ClamAV を Install »

PC and PC troubles」カテゴリの記事

Comments

Post a comment

Comments are moderated, and will not appear on this weblog until the author has approved them.

(Not displayed with comment.)

« Linux Mint 19.1 MATE update Error bionic-security/restricted armhf Packages | Main | Linux Mint 19.1 に Virus 対応ソフト ClamAV を Install »

October 2019
Sun Mon Tue Wed Thu Fri Sat
    1 2 3 4 5
6 7 8 9 10 11 12
13 14 15 16 17 18 19
20 21 22 23 24 25 26
27 28 29 30 31    

Recent Trackbacks

無料ブログはココログ